Протокол Steam не работает в Firefox

Тема в разделе "Разговоры о Steam", создана пользователем hebroid, 11 июл 2014.

  1. hebroid

    hebroid Headcrab

    Сообщения:
    4.504
    Симпатии:
    4.094
    Достижения:
    10
    Прошу помощи. Уже давно заметил, что у меня в Firefox не работает протокол Steam:

    [​IMG]

    В гугле ничего не нашел. У кого какие есть идеи на этот счет?
     
    #1 11 июл 2014
  2. Rooney_10

    Rooney_10

    Сообщения:
    13
    Симпатии:
    35
    Достижения:
    0
    В настройках есть вкладка Приложения, которая должна выглядеть примерно так:
    [​IMG]
    там все ок?
     
    #2 11 июл 2014
  3. hebroid

    hebroid Headcrab

    Сообщения:
    4.504
    Симпатии:
    4.094
    Достижения:
    10
    Rooney_10, в настройках все ок:

    [​IMG]
     
    #3 11 июл 2014
  4. Rooney_10

    Rooney_10

    Сообщения:
    13
    Симпатии:
    35
    Достижения:
    0
    hebroid, попробуй отключить все расширения. Возможно, что одно из них конфликтует со ссылками steam://
     
    #4 11 июл 2014
  5. hebroid

    hebroid Headcrab

    Сообщения:
    4.504
    Симпатии:
    4.094
    Достижения:
    10
    Rooney_10, запустил Firefox в безопасном режиме - бесполезно.
     
    #5 12 июл 2014
  6. Rooney_10

    Rooney_10

    Сообщения:
    13
    Симпатии:
    35
    Достижения:
    0
    hebroid, скорее всего проблема в реестре. Попробуй переустановить Steam, в этом случае, если я не ошибаюсь, он должен перезаписать свои записи в реестре. У меня была такая же проблема с magnet-ссылками, помогла только переустановка торрент-клиента.
     
    #6 12 июл 2014
  7. hebroid

    hebroid Headcrab

    Сообщения:
    4.504
    Симпатии:
    4.094
    Достижения:
    10
    Полностью удалил и переустановил, проблема осталась.

    [upd=1405166202][/upd]
    По-моему, эта проблема у меня появилась после установки Windows 7, вроде на XP все работало нормально.

    [upd=1405168557][/upd]
    В-общем, проблему решил:

    Код:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\steam]
    @="URL:steam protocol"
    "URL Protocol"=""
    
    [HKEY_CLASSES_ROOT\steam\DefaultIcon]
    @="steam.exe"
    
    [HKEY_CLASSES_ROOT\steam\Shell]
    
    [HKEY_CLASSES_ROOT\steam\Shell\Open]
    
    [HKEY_CLASSES_ROOT\steam\Shell\Open\Command]
    @="\"D:\\Games\\Steam\\steam.exe\" \"%1\""
    Создаем .reg файл с таким содержимым, путь меняем на свой. Запускаем - проблема решена.
     
    #7 12 июл 2014